aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-daemonize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-daemonize/APKBUILD')
-rw-r--r--testing/py3-daemonize/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-daemonize/APKBUILD b/testing/py3-daemonize/APKBUILD
new file mode 100644
index 00000000000..7e0876cf599
--- /dev/null
+++ b/testing/py3-daemonize/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=py3-daemonize
+_pkgname=daemonize
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Library for writing system daemons in Python"
+url="https://github.com/thesharp/daemonize"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # No testsuite
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-daemonize # Backwards compatibility
+provides=py-daemonize=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="5043db681b36028e3168cd2ad86235e0962bbdc46ded2f631ab36846083b0817524cddd7a9333997a82b4888b2490391bac2e1cfd043c1ddc129da54d2cbd6bd daemonize-2.5.0.tar.gz"