aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dexml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dexml/APKBUILD')
-rw-r--r--testing/py3-dexml/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/testing/py3-dexml/APKBUILD b/testing/py3-dexml/APKBUILD
index 5abbb5664d6..127f8f7fca7 100644
--- a/testing/py3-dexml/APKBUILD
+++ b/testing/py3-dexml/APKBUILD
@@ -3,26 +3,33 @@
pkgname=py3-dexml
_pkgname=dexml
pkgver=0.5.1
-pkgrel=4
+pkgrel=9
pkgdesc="A simple Object-XML mapper for Python"
url="https://pypi.org/project/dexml"
arch="noarch"
license="MIT"
-replaces="py-dexml" # for backwards compatibility
+replaces="py-dexml" # for backwards compatibility
provides="py-dexml=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-makedepends="python3-dev py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+makedepends="python3-dev py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ py3.patch
+ "
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="b8ac2b9f875ac7cf699eb9ee17adb8678ed8d4a796130bbb60f05431207adb68f490b7a7a41600acbc16a3cc08d55f22d91a13e53fe3d835a322709ee3446c9f dexml-0.5.1.tar.gz"
+sha512sums="
+b8ac2b9f875ac7cf699eb9ee17adb8678ed8d4a796130bbb60f05431207adb68f490b7a7a41600acbc16a3cc08d55f22d91a13e53fe3d835a322709ee3446c9f dexml-0.5.1.tar.gz
+de2ea4ce179d64c0bb3bf66a40739b4f1b01504b43e74666f60882d86da83d22edbe4606bd24c9605947ac677cc69169e5270df8574b8c9737830959bb16300f py3.patch
+"