aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-diskcache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-diskcache/APKBUILD')
-rw-r--r--testing/py3-diskcache/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-diskcache/APKBUILD b/testing/py3-diskcache/APKBUILD
index f1298d7d8f6..b830a3a3073 100644
--- a/testing/py3-diskcache/APKBUILD
+++ b/testing/py3-diskcache/APKBUILD
@@ -1,16 +1,17 @@
# Contributor:
# Maintainer:
pkgname=py3-diskcache
-pkgver=4.1.0
-pkgrel=1
+pkgver=5.6.3
+pkgrel=0
pkgdesc="disk caching implementation"
options="!check" # test_incr_update_keyerror fails
-url="http://www.grantjenks.com/docs/diskcache/"
+url="https://grantjenks.com/docs/diskcache/"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pytest-xdist py3-mock py3-django"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/grantjenks/python-diskcache/archive/v$pkgver.tar.gz"
builddir="$srcdir"/python-diskcache-$pkgver
@@ -26,7 +27,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="3871e56fa9a50942e29e200df74d7f4312d21a0f51d6be2041ce71efd3c1d0c204cc1df5ac1f92825314c742bb48bf8b0a3929cee225055903953e095701c8e3 py3-diskcache-4.1.0.tar.gz"
+sha512sums="
+476d677d88212aa3f9a6e8d12c3e7076cc6a06973d703ed0b2c550b4b4e916b24fb7d8f33c7174854015886fab26e2707b134328d2bc3e144aef5510e7bc0f7c py3-diskcache-5.6.3.tar.gz
+"