aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-diskcache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-diskcache/APKBUILD')
-rw-r--r--testing/py3-diskcache/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/testing/py3-diskcache/APKBUILD b/testing/py3-diskcache/APKBUILD
index 1cb60677efa..489341364a3 100644
--- a/testing/py3-diskcache/APKBUILD
+++ b/testing/py3-diskcache/APKBUILD
@@ -1,16 +1,17 @@
# Contributor:
# Maintainer:
pkgname=py3-diskcache
-pkgver=5.3.0
-pkgrel=0
+pkgver=5.6.3
+pkgrel=1
pkgdesc="disk caching implementation"
options="!check" # test_incr_update_keyerror fails
-url="http://www.grantjenks.com/docs/diskcache/"
+url="https://grantjenks.com/docs/diskcache/"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pytest-xdist py3-mock py3-django"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/grantjenks/python-diskcache/archive/v$pkgver.tar.gz"
builddir="$srcdir"/python-diskcache-$pkgver
@@ -26,9 +27,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-106c8eb8320153e42e076927d51fa75d30b92156e17a75756e0392028cb6b5054af9af66b93aa69b7a7105012f0b92fe942ee447a75e53e005b56eb0b067dc38 py3-diskcache-5.3.0.tar.gz
+476d677d88212aa3f9a6e8d12c3e7076cc6a06973d703ed0b2c550b4b4e916b24fb7d8f33c7174854015886fab26e2707b134328d2bc3e144aef5510e7bc0f7c py3-diskcache-5.6.3.tar.gz
"