aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-django-mptt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-django-mptt/APKBUILD')
-rw-r--r--testing/py3-django-mptt/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/testing/py3-django-mptt/APKBUILD b/testing/py3-django-mptt/APKBUILD
index 8b76a9dff01..ed15b7a845c 100644
--- a/testing/py3-django-mptt/APKBUILD
+++ b/testing/py3-django-mptt/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-django-mptt
_pkgname=django-mptt
-pkgver=0.12.0
-pkgrel=0
+pkgver=0.16
+pkgrel=2
pkgdesc="Utilities for implementing a modified pre-order traversal tree in django"
options="!check" # Requires running django instance
url="https://github.com/django-mptt/django-mptt"
arch="noarch"
license="MIT"
depends="py3-django py3-django-js-asset"
-makedepends="py3-setuptools"
+makedepends="py3-hatchling py3-gpep517"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/django-mptt/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -18,13 +19,16 @@ replaces="py-django-mptt" # Backwards compatibiity
provides="py-django-mptt=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py --quiet build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-fae2991aaa0b300d725242c94401818a5d0620a1180b86f0fc503c5943ec4012b129dfa25999f1393d678fc2588fd03152a361cb6e0a271c82f8c45411e9a09e py3-django-mptt-0.12.0.tar.gz
+98f40f2b51e8d48f6b872d6775968282d135ca60d13e9a36a811ef54506f957fa5abe3098e1f68476709d80966558db69809f3d2ff5f5a4a1a69c43931e4c141 py3-django-mptt-0.16.tar.gz
"