aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-django-timezone-field/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-django-timezone-field/APKBUILD')
-rw-r--r--testing/py3-django-timezone-field/APKBUILD39
1 files changed, 27 insertions, 12 deletions
diff --git a/testing/py3-django-timezone-field/APKBUILD b/testing/py3-django-timezone-field/APKBUILD
index 91635cc7549..3b29ace2a2b 100644
--- a/testing/py3-django-timezone-field/APKBUILD
+++ b/testing/py3-django-timezone-field/APKBUILD
@@ -1,35 +1,50 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-django-timezone-field
_pkgname=django-timezone-field
-pkgver=4.2.1
-pkgrel=0
+pkgver=6.1.0
+pkgrel=2
pkgdesc="Django app providing database and form fields for pytz timezone objects"
-options="!check" # Testsuite is only coverage and flake8 tests
-url="https://pypi.python.org/pypi/django-timezone-field"
+url="https://pypi.org/project/django-timezone-field"
arch="noarch"
license="BSD-2-Clause"
-depends="py3-django py3-tz"
-makedepends="py3-setuptools"
+depends="py3-django"
+makedepends="
+ py3-gpep517
+ py3-poetry-core
+ "
+checkdepends="
+ py3-django-rest-framework
+ py3-pytest
+ py3-pytest-django
+ py3-tz
+ tzdata
+ "
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mfogel/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+options="!check" #fails with funcargs error, likely lazy_fixture incompatibility in test suite
replaces="py-django-timezone-field" # Backwards compatibility
provides="py-django-timezone-field=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
-
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 tests.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-4c2da420c3aaffa23d8cdb66dbbe4b2ea8638de5a45d9e381bf9af980e52eba77fc03a2b8fee8497662199cdc9436d56543c0f6316e74ae5da68187a305c34a2 py3-django-timezone-field-4.2.1.tar.gz
+b070e55a2a5196de1fcae4bd19979caf9d84c234a4e379d82dab843541cf99a0acced9a6996e35afe6b40d1bf737d522d34b91df10596e7365f85cfbe0597015 py3-django-timezone-field-6.1.0.tar.gz
"