aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dnslib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dnslib/APKBUILD')
-rw-r--r--testing/py3-dnslib/APKBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/testing/py3-dnslib/APKBUILD b/testing/py3-dnslib/APKBUILD
index 10183cbc058..e4d86d7e7bf 100644
--- a/testing/py3-dnslib/APKBUILD
+++ b/testing/py3-dnslib/APKBUILD
@@ -1,33 +1,41 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-dnslib
-_pkgname=dnslib
-pkgver=0.9.16
-pkgrel=0
+pkgver=0.9.24
+pkgrel=1
pkgdesc="simple library to encode/decode DNS wire-format packets"
url="https://github.com/paulc/dnslib"
arch="noarch"
license="BSD-2-Clause"
-depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/d/dnslib/dnslib-$pkgver.tar.gz"
+builddir="$srcdir/dnslib-$pkgver"
replaces=py-dnslib # Backwards compatibility
provides=py-dnslib=$pkgver-r$pkgrel # Backwards compatibility
+# secfixes:
+# 0.9.19-r0:
+# - CVE-2022-22846
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" python3 dnslib/test_decode.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 dnslib/test_decode.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-debe8a68cd88224a42aec3800683e803f8928dfd67645b58e0fd7f74eff6b22bad09a84e7b322c3e19e7aecb7b70ea086a2ab4b3f8d91c11dc3efc6f8b288ff2 dnslib-0.9.16.tar.gz
+95163676394f417b7d41f572c9a933728061b430ffbe670cdd44486a6447615273d2ac2805daf839721c247d902713e70ad183c580c8515f4e5e3d740986e633 dnslib-0.9.24.tar.gz
"