aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dpath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dpath/APKBUILD')
-rw-r--r--testing/py3-dpath/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/py3-dpath/APKBUILD b/testing/py3-dpath/APKBUILD
index 994ce3bac9f..2cc9ce281dd 100644
--- a/testing/py3-dpath/APKBUILD
+++ b/testing/py3-dpath/APKBUILD
@@ -2,28 +2,34 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-dpath
_pkgname=dpath
-pkgver=1.4.2
-pkgrel=2
+pkgver=2.1.6
+pkgrel=1
pkgdesc="Filesystem-like pathing and searching for dictionaries"
-url="https://www.github.com/akesterson/dpath-python"
+url="https://github.com/dpath-maintainers/dpath-python"
arch="noarch"
license="MIT"
replaces="py-dpath" # for backwards compatibility
provides="py-dpath=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-setuptools"
+checkdepends="py3-hypothesis py3-mock py3-nose2 py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ PYTHONPATH="$builddir"/build/lib pytest-3
+}
+
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="8b868ba63a810ef18a58a6452cf6f30eeeee44ea4bd27dbc7d0efcce116adcbb3e2793e89bf94a5aa2d8ec893f96c32dd523f102e5a0da5124a88c7d1dff00d2 dpath-1.4.2.tar.gz"
+sha512sums="
+2f2dac39b6e1ad2effd8d61ac4acf6619205423389ecebc54061aa10ec11ce3236ea666b632a7dca349e9b7a6579815c97e01c930eaa1a99d965e37b9825b82c dpath-2.1.6.tar.gz
+"