aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dpath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dpath/APKBUILD')
-rw-r--r--testing/py3-dpath/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-dpath/APKBUILD b/testing/py3-dpath/APKBUILD
index e997186e1fc..2cc9ce281dd 100644
--- a/testing/py3-dpath/APKBUILD
+++ b/testing/py3-dpath/APKBUILD
@@ -2,17 +2,18 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-dpath
_pkgname=dpath
-pkgver=2.0.1
+pkgver=2.1.6
pkgrel=1
pkgdesc="Filesystem-like pathing and searching for dictionaries"
-url="https://www.github.com/akesterson/dpath-python"
+url="https://github.com/dpath-maintainers/dpath-python"
arch="noarch"
license="MIT"
replaces="py-dpath" # for backwards compatibility
provides="py-dpath=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
makedepends="py3-setuptools"
-checkdepends="py3-hypothesis py3-mock py3-nose py3-pytest"
+checkdepends="py3-hypothesis py3-mock py3-nose2 py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -26,7 +27,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="4f4c2ccb91fe818127505e909c2021fec4ebf730d791ff12de720eddbb5c3f08f158e07f80332f7ab9450961a8eca92c51d9eba17fb3a3df2c34aee2dc655613 dpath-2.0.1.tar.gz"
+sha512sums="
+2f2dac39b6e1ad2effd8d61ac4acf6619205423389ecebc54061aa10ec11ce3236ea666b632a7dca349e9b7a6579815c97e01c930eaa1a99d965e37b9825b82c dpath-2.1.6.tar.gz
+"