aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dulwich/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dulwich/APKBUILD')
-rw-r--r--testing/py3-dulwich/APKBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/testing/py3-dulwich/APKBUILD b/testing/py3-dulwich/APKBUILD
deleted file mode 100644
index d713b10fcc1..00000000000
--- a/testing/py3-dulwich/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-dulwich
-_pkgname=dulwich
-pkgver=0.19.16
-pkgrel=0
-pkgdesc="A python implementation of the Git file formats and protocols"
-url="https://www.dulwich.io"
-arch="all"
-license="GPL-2.0-or-later OR Apache-2.0"
-options="!check" # Tests are failing (http-backend)
-depends="py3-certifi py3-urllib3"
-makedepends="py3-setuptools python3-dev"
-checkdepends="py3-mock"
-source="https://github.com/dulwich/dulwich/archive/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-dulwich-$pkgver
-
-replaces="py-dulwich" # Backwards compatibility
-provides="py-dulwich=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 -m unittest dulwich.tests.test_suite
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="a1452fb25943f4e71f338763e08babe40c61b6bb6be6a076c9d0f7781b429a40eb574635e9146d2b8d245cf7010a99428103dd7d910eeb7b296b1b91a0869425 dulwich-0.19.16.tar.gz"