aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-eradicate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-eradicate/APKBUILD')
-rw-r--r--testing/py3-eradicate/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-eradicate/APKBUILD b/testing/py3-eradicate/APKBUILD
new file mode 100644
index 00000000000..3003a9ed866
--- /dev/null
+++ b/testing/py3-eradicate/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rejah Rehim <rejah@beaglesecurity.com>
+# Maintainer: Rejah Rehim <rejah@beaglesecurity.com>
+pkgname=py3-eradicate
+_pkgname=eradicate
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Removes commented-out code"
+options="!check" # no test suite
+url="https://github.com/myint/eradicate"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/e/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+ install -Dm644 README.rst -t "$pkgdir"/usr/share/doc/"$pkgname"
+}
+
+sha512sums="
+3b2498277e8aa6e36f1dbab0731b28d22034b95564c300e067151fe5a6c8f124661f169e43290a57950588fcd8c8f27b990755bdba7e28afcc0fee6b82c1c07f eradicate-2.3.0.tar.gz
+"