aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-euclid3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-euclid3/APKBUILD')
-rw-r--r--testing/py3-euclid3/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/py3-euclid3/APKBUILD b/testing/py3-euclid3/APKBUILD
index ebe406a9446..2fe23088eb5 100644
--- a/testing/py3-euclid3/APKBUILD
+++ b/testing/py3-euclid3/APKBUILD
@@ -1,7 +1,8 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-euclid3
pkgver=0.01
-pkgrel=2
+pkgrel=7
pkgdesc="Vector, matrix, quaternion and some geometry in 2D and 3D for Python 3"
url="https://github.com/euclid3/euclid3"
arch="noarch"
@@ -10,11 +11,10 @@ depends="python3"
makedepends="
py3-setuptools
"
-_pyname="euclid3"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/e/euclid3/euclid3-$pkgver.tar.gz"
builddir="$srcdir/euclid3-$pkgver"
-options="!check" # Version 0.01 contains no tests :-/
+options="!check" # no tests
build() {
python3 setup.py build
@@ -25,6 +25,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="c4e5e2770ab4ede08904fc3b76e50d6812944ed226c9db52f2da8d100370e20ea6031ca554ae44d72d53e96727d163bd3cc8da7bf175539de10749da77877b0b euclid3-0.01.tar.gz"
+
+sha512sums="
+c4e5e2770ab4ede08904fc3b76e50d6812944ed226c9db52f2da8d100370e20ea6031ca554ae44d72d53e96727d163bd3cc8da7bf175539de10749da77877b0b euclid3-0.01.tar.gz
+"