aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-fastavro/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-fastavro/APKBUILD')
-rw-r--r--testing/py3-fastavro/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/testing/py3-fastavro/APKBUILD b/testing/py3-fastavro/APKBUILD
index 4ba0ad2bdb4..b9b0c4f3da1 100644
--- a/testing/py3-fastavro/APKBUILD
+++ b/testing/py3-fastavro/APKBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Gennady Feldman <gena01@gmail.com>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
# Contributor: Gennady Feldman <gena01@gmail.com>
# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-fastavro
_pkgname=fastavro
-pkgver=1.5.1
-pkgrel=0
+pkgver=1.9.4
+pkgrel=1
pkgdesc="Fast Avro for Python"
# Tests for optional zstd and snappy codecs require
# unpackaged python modules 'zstandard' and 'python-snappy'
@@ -12,14 +12,18 @@ options="!check"
url="https://github.com/fastavro/fastavro"
arch="all !x86" # _tz_ tests fail
license="MIT"
-depends="py3-six"
-makedepends="py3-setuptools python3-dev cython"
-checkdepends="py3-pytest py3-numpy"
+depends="python3"
+makedepends="py3-gpep517 py3-setuptools python3-dev cython py3-wheel"
+checkdepends="py3-pytest-xdist py3-numpy"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/fastavro/fastavro/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- FASTAVRO_USE_CYTHON=1 python3 setup.py build
+ FASTAVRO_USE_CYTHON=1 \
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -27,9 +31,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-e79e1a1e66e53faf41ee7a37d6576f28eccbe6e34c545f370cb7ed57bf583d443077682370f9aa4c6288b4b40e0d4ffca1179cfa7df317cfcc8fae18f9406d50 py3-fastavro-1.5.1.tar.gz
+88a9d7dbf4c8870dda4c7c8265649c6c4e405d6cf5e10b39029e4ec1cd762237daae6d5b9a317886f21b71625fd73c401c7518168282b1f2d7b9c02fbb825931 py3-fastavro-1.9.4.tar.gz
"