aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-fastavro/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-fastavro/APKBUILD')
-rw-r--r--testing/py3-fastavro/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/testing/py3-fastavro/APKBUILD b/testing/py3-fastavro/APKBUILD
index f4792519732..9f03e1425f9 100644
--- a/testing/py3-fastavro/APKBUILD
+++ b/testing/py3-fastavro/APKBUILD
@@ -1,24 +1,29 @@
-# Maintainer: Gennady Feldman <gena01@gmail.com>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
# Contributor: Gennady Feldman <gena01@gmail.com>
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-fastavro
_pkgname=fastavro
-pkgver=1.4.4
+pkgver=1.9.4
pkgrel=0
pkgdesc="Fast Avro for Python"
# Tests for optional zstd and snappy codecs require
# unpackaged python modules 'zstandard' and 'python-snappy'
options="!check"
url="https://github.com/fastavro/fastavro"
-arch="all !x86 !mips !mips64" # _tz_ tests fail, blocked by numpy on mips
+arch="all !x86" # _tz_ tests fail
license="MIT"
-depends="py3-six"
-makedepends="py3-setuptools python3-dev cython"
-checkdepends="py3-pytest py3-numpy"
+depends="python3"
+makedepends="py3-gpep517 py3-setuptools python3-dev cython py3-wheel"
+checkdepends="py3-pytest-xdist py3-numpy"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/fastavro/fastavro/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- FASTAVRO_USE_CYTHON=1 python3 setup.py build
+ FASTAVRO_USE_CYTHON=1 \
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -26,9 +31,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-352fc032156c9bd5b062843a10836d46a601876d87302c83230b040c47e8c66738500231aa94553e1bec097156c6ef2d43bc8f5ba4456c7c9b058f6f8eae54e3 py3-fastavro-1.4.4.tar.gz
+88a9d7dbf4c8870dda4c7c8265649c6c4e405d6cf5e10b39029e4ec1cd762237daae6d5b9a317886f21b71625fd73c401c7518168282b1f2d7b9c02fbb825931 py3-fastavro-1.9.4.tar.gz
"