aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-blind-except/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flake8-blind-except/APKBUILD')
-rw-r--r--testing/py3-flake8-blind-except/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/testing/py3-flake8-blind-except/APKBUILD b/testing/py3-flake8-blind-except/APKBUILD
index 3813893a671..9f4b4e3962b 100644
--- a/testing/py3-flake8-blind-except/APKBUILD
+++ b/testing/py3-flake8-blind-except/APKBUILD
@@ -2,26 +2,33 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-flake8-blind-except
_pkgname=flake8-blind-except
-pkgver=0.1.1
-pkgrel=2
+pkgver=0.2.1
+pkgrel=4
pkgdesc="Extension for flake8 which checks for blind except: statements"
options="!check" # No testsuite
url="https://github.com/elijahandrews/flake8-blind-except"
arch="noarch"
license="MIT"
depends="py3-flake8 py3-setuptools"
+makedepends="py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flake8-blind-except" # Backwards compatibility
+replaces="py-flake8-blind-except" # Backwards compatibility
provides="py-flake8-blind-except=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="3a74e626b87e570a079dd54ac4abbdabf2daa0b5bc64b8205f54747ddb8ce8dd4ded9dd3222307f879dcda8fc9aa47dcfacf401da27d7717888cd3d9691a0513 flake8-blind-except-0.1.1.tar.gz"
+sha512sums="
+0917df4610c6c25319f6382b92f8a2a67519b2a6266f43ae23ea2e44f0416f93cacdd7cc39bb69c817f608becf726839c81c93425ecf66ffb95b49eeb2e0145b flake8-blind-except-0.2.1.tar.gz
+"