aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-polyfill/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flake8-polyfill/APKBUILD')
-rw-r--r--testing/py3-flake8-polyfill/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-flake8-polyfill/APKBUILD b/testing/py3-flake8-polyfill/APKBUILD
index 439eea6b984..f3066a8500a 100644
--- a/testing/py3-flake8-polyfill/APKBUILD
+++ b/testing/py3-flake8-polyfill/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-flake8-polyfill
pkgver=1.0.2
-pkgrel=0
+pkgrel=4
pkgdesc="compatibility helpers for Flake8 plugins that intend to support Flake8 2.x and 3.x simultaneously"
url="https://gitlab.com/pycqa/flake8-polyfill"
arch="all"
license="MIT"
depends="py3-flake8"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/f/flake8-polyfill/flake8-polyfill-$pkgver.tar.gz"
builddir="$srcdir/flake8-polyfill-$pkgver"
@@ -20,7 +21,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="767a599aacbe87328b3e36bd85e0841870760ed9bd95dd3a4a9084edc6f0ae89f8203d565c2b075f16f1db21b647c17b2aa59b08e4702109d7e5f79f36d9f3fa flake8-polyfill-1.0.2.tar.gz"