aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-print/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flake8-print/APKBUILD')
-rw-r--r--testing/py3-flake8-print/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/py3-flake8-print/APKBUILD b/testing/py3-flake8-print/APKBUILD
index 6fcafc7f9a3..303d08ecc45 100644
--- a/testing/py3-flake8-print/APKBUILD
+++ b/testing/py3-flake8-print/APKBUILD
@@ -2,26 +2,32 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-flake8-print
_pkgname=flake8-print
-pkgver=3.1.0
-pkgrel=2
+pkgver=5.0.0
+pkgrel=5
pkgdesc="Extension for flake8 which lint for print statements"
url="https://github.com/jbkahn/flake8-print"
arch="noarch"
license="MIT"
-depends="py3-flake8 py3-six"
-makedepends="py3-setuptools py3-pytest-runner"
+depends="py3-flake8 python3"
+makedepends="py3-poetry-core py3-pytest-runner py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flake8-print" # Backwards compatiblity
+replaces="py-flake8-print" # Backwards compatiblity
provides="py-flake8-print=$pkgver-r$pkgrel" # Backwards compatiblity
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="9d8ea7017eebedf365a45cc3f1bcca2aec73c5257a935cd5d5bc927d5d1f06866b7e072f70e2a8a13e61c3416af6afbaa1fa6225dad087bbdc796656f0eda1f0 flake8-print-3.1.0.tar.gz"
+sha512sums="
+69fd20fa92b795c8efa5971f9e17e6ac579fb642b3c07fafc4143b4d01acc2c577dbba6fd818c8ad92ad60709986777da59b804f2fec768f210a64b88252a987 flake8-print-5.0.0.tar.gz
+"