aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-snippets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flake8-snippets/APKBUILD')
-rw-r--r--testing/py3-flake8-snippets/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-flake8-snippets/APKBUILD b/testing/py3-flake8-snippets/APKBUILD
index e67f9a345c9..c667f7c6e65 100644
--- a/testing/py3-flake8-snippets/APKBUILD
+++ b/testing/py3-flake8-snippets/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-flake8-snippets
_pkgname=flake8-snippets
pkgver=0.2
-pkgrel=2
+pkgrel=8
pkgdesc="Extension for flake8 which lint for code snippets"
-url="https://github.com/bitmazk/flake8-snippets"
+url="https://github.com/bitlabstudio/flake8-snippets"
arch="noarch"
license="MIT"
depends="py3-flake8"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flake8-snippets" # Backwards compatibility
+replaces="py-flake8-snippets" # Backwards compatibility
provides="py-flake8-snippets=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="b7a3a335770912da9c162cb002550c299034e08c40b9b64d352b048650d1fe772508b1a226b873e65b8f6fea856fd2a2099e6bb84bc1e121730d19d32eae5e21 flake8-snippets-0.2.tar.gz"