aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-todo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flake8-todo/APKBUILD')
-rw-r--r--testing/py3-flake8-todo/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-flake8-todo/APKBUILD b/testing/py3-flake8-todo/APKBUILD
index fbb033f0f52..d6a1034237c 100644
--- a/testing/py3-flake8-todo/APKBUILD
+++ b/testing/py3-flake8-todo/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-flake8-todo
_pkgname=flake8-todo
pkgver=0.7
-pkgrel=2
+pkgrel=7
pkgdesc="TODO notes checker plugin for flake8"
url="https://github.com/schlamar/flake8-todo"
arch="noarch"
license="MIT"
depends="py3-flake8"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flake8-todo" # Backwards compatibility
+replaces="py-flake8-todo" # Backwards compatibility
provides="py-flake8-todo=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="d7a2259b531627c8866f1d7c29664f61dcd01a523f55efc851052f8ed5e1bc13108d7011093a1aedda2c343e1b127999aa91f65a5f29b218efc2bfc7064fdd96 flake8-todo-0.7.tar.gz"