aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-basicauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-basicauth/APKBUILD')
-rw-r--r--testing/py3-flask-basicauth/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-flask-basicauth/APKBUILD b/testing/py3-flask-basicauth/APKBUILD
index 410a413b481..a939ce12048 100644
--- a/testing/py3-flask-basicauth/APKBUILD
+++ b/testing/py3-flask-basicauth/APKBUILD
@@ -3,26 +3,30 @@
pkgname=py3-flask-basicauth
_pkgname=Flask-BasicAuth
pkgver=0.2.0
-pkgrel=3
+pkgrel=9
pkgdesc="Flask HTTP basic access authentication"
options="!check" # Broken testsuite
-url="https://pypi.python.org/pypi/Flask-BasicAuth"
+url="https://pypi.org/project/Flask-BasicAuth"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-flask"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flask-basicauth" # Backwards compatibility
+replaces="py-flask-basicauth" # Backwards compatibility
provides="py-flask-basicauth=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="921b05e273e9a4b06f00cb68b68ddca20328f1a3afd1dd779d973792f1382a2bf2c6a8f70719e097dfa3d00d8e511fc35fba218de3fbb8ed6197ddbaa8027f93 Flask-BasicAuth-0.2.0.tar.gz"