aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-bootstrap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-bootstrap/APKBUILD')
-rw-r--r--testing/py3-flask-bootstrap/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-flask-bootstrap/APKBUILD b/testing/py3-flask-bootstrap/APKBUILD
index 8032e997c1d..b5129a1361b 100644
--- a/testing/py3-flask-bootstrap/APKBUILD
+++ b/testing/py3-flask-bootstrap/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-flask-bootstrap
_pkgname=Flask-Bootstrap
pkgver=3.3.7.1
-pkgrel=2
+pkgrel=8
pkgdesc="Flask bootstrap extension"
-url="https://pypi.python.org/pypi/Flask-Bootstrap"
+url="https://pypi.org/project/Flask-Bootstrap"
arch="noarch"
license="BSD-3-Clause and Apache-2.0"
depends="python3 py3-flask py3-dominate py3-visitor"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flask-bootstrap" # Backwards compatibility
+replaces="py-flask-bootstrap" # Backwards compatibility
provides="py-flask-bootstrap=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="23500d9575de5c52fcfd8a41bb7d5680440a0f1bae25e7a089b7f0e3885304a4c7d5b916f98adbfe80b98c8d107feef0c5c282e7a4bec7038310e778da4ca2e7 Flask-Bootstrap-3.3.7.1.tar.gz"