aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-gzip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-gzip/APKBUILD')
-rw-r--r--testing/py3-flask-gzip/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-flask-gzip/APKBUILD b/testing/py3-flask-gzip/APKBUILD
index 7693dd6830c..f2b0c76a52d 100644
--- a/testing/py3-flask-gzip/APKBUILD
+++ b/testing/py3-flask-gzip/APKBUILD
@@ -3,22 +3,26 @@
pkgname=py3-flask-gzip
_pkgname=Flask-gzip
pkgver=0.2
-pkgrel=2
+pkgrel=8
pkgdesc="Compress responses in your Flask app with gzip"
-url="https://pypi.python.org/pypi/Flask-gzip"
+url="https://pypi.org/project/Flask-gzip"
arch="noarch"
license="BSD-3-Clause"
depends="py3-flask"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="0625fcab11c607209a8b95455621e347bd71d5be47ae1af09f11f284d495f29d0e23b7f228eeca9bed1615fffa48f036eddfdf2abab78b81b0d693a9b0b94fd8 Flask-gzip-0.2.tar.gz"