aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-loopback/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-loopback/APKBUILD')
-rw-r--r--testing/py3-flask-loopback/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-flask-loopback/APKBUILD b/testing/py3-flask-loopback/APKBUILD
index b8f706e5167..5848d8795a4 100644
--- a/testing/py3-flask-loopback/APKBUILD
+++ b/testing/py3-flask-loopback/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-flask-loopback
_pkgname=Flask-Loopback
pkgver=1.4.7
-pkgrel=1
+pkgrel=7
pkgdesc="A library to create requests without network connection"
-url="https://pypi.python.org/pypi/Flask-Loopback"
+url="https://pypi.org/project/Flask-Loopback"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-flask py3-requests py3-urlobject"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flask-loopback" # Backwards compatibility
+replaces="py-flask-loopback" # Backwards compatibility
provides="py-flask-loopback=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="556f6182fabeabff3b173ee030f1986c4a791760e388ae5352b883a3ad79e3495ae9a3a7e3ee3826de149665609ba01f25fb993cebe4ea8d63ef5c14c18f57df Flask-Loopback-1.4.7.tar.gz"