aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-paginate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-paginate/APKBUILD')
-rw-r--r--testing/py3-flask-paginate/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-flask-paginate/APKBUILD b/testing/py3-flask-paginate/APKBUILD
new file mode 100644
index 00000000000..5f2a692fbbf
--- /dev/null
+++ b/testing/py3-flask-paginate/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-flask-paginate
+pkgver=0.8.1
+pkgrel=6
+pkgdesc="Simple paginate support for Flask"
+url="https://pypi.org/project/Flask-paginate"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-flask"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lixxu/flask-paginate/archive/$pkgver.tar.gz"
+builddir="$srcdir"/flask-paginate-$pkgver
+
+replaces="py-flask-paginate" # Backwards compatibility
+provides="py-flask-paginate=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+package() {
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+ca226c79bd944a19760048c1289b554ee048f4f8d1f231f5545423843b7c0616d52ee8024cc68628e11c5f528972897d7fdb1630f87063bbd0e40c4dacf91224 py3-flask-paginate-0.8.1.tar.gz
+"