aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-paginate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-paginate/APKBUILD')
-rw-r--r--testing/py3-flask-paginate/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-flask-paginate/APKBUILD b/testing/py3-flask-paginate/APKBUILD
index e21ec1e47f1..5f2a692fbbf 100644
--- a/testing/py3-flask-paginate/APKBUILD
+++ b/testing/py3-flask-paginate/APKBUILD
@@ -2,25 +2,29 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-flask-paginate
pkgver=0.8.1
-pkgrel=0
+pkgrel=6
pkgdesc="Simple paginate support for Flask"
-url="https://pypi.python.org/pypi/Flask-paginate"
+url="https://pypi.org/project/Flask-paginate"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-flask"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/lixxu/flask-paginate/archive/$pkgver.tar.gz"
builddir="$srcdir"/flask-paginate-$pkgver
-replaces="py-flask-paginate" # Backwards compatibility
+replaces="py-flask-paginate" # Backwards compatibility
provides="py-flask-paginate=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="