aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-peewee/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-peewee/APKBUILD')
-rw-r--r--testing/py3-flask-peewee/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-flask-peewee/APKBUILD b/testing/py3-flask-peewee/APKBUILD
index e429f36c80b..cd2fccefb3a 100644
--- a/testing/py3-flask-peewee/APKBUILD
+++ b/testing/py3-flask-peewee/APKBUILD
@@ -3,24 +3,28 @@
pkgname=py3-flask-peewee
_pkgname=flask-peewee
pkgver=3.0.4
-pkgrel=0
+pkgrel=6
pkgdesc="Flask integration for peewee"
-url="http://pypi.python.org/pypi/flask-peewee"
+url="https://pypi.org/project/flask-peewee"
arch="noarch"
license="MIT"
depends="py3-flask py3-jinja2 py3-peewee py3-werkzeug py3-wtf-peewee
py3-wtforms"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="