aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-principal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-principal/APKBUILD')
-rw-r--r--testing/py3-flask-principal/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/testing/py3-flask-principal/APKBUILD b/testing/py3-flask-principal/APKBUILD
index 96354f9528c..bd64616063d 100644
--- a/testing/py3-flask-principal/APKBUILD
+++ b/testing/py3-flask-principal/APKBUILD
@@ -3,30 +3,36 @@
pkgname=py3-flask-principal
_pkgname=flask-principal
pkgver=0.4.0
-pkgrel=3
+pkgrel=8
pkgdesc="Flask Identity management"
url="https://pythonhosted.org/Flask-Principal/"
arch="noarch"
license="MIT"
depends="python3 py3-blinker py3-flask"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
checkdepends="py3-nose"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mattupstate/flask-principal/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flask-principal" # Backwards compatibility
+replaces="py-flask-principal" # Backwards compatibility
provides="py-flask-principal=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- nosetests
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m nose
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="ed8cb28c4e8d936de96db0bf9f7cb45b253dc204c4b8f8dd8022ef1552592ff6324b4a33d3ee862794a6e20eb8c32a0365e7b9397d427da5022c5ded3dfa308a py3-flask-principal-0.4.0.tar.gz"