aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-restaction/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-flask-restaction/APKBUILD')
-rw-r--r--testing/py3-flask-restaction/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-flask-restaction/APKBUILD b/testing/py3-flask-restaction/APKBUILD
index b5f46b970fb..f44a60efdc7 100644
--- a/testing/py3-flask-restaction/APKBUILD
+++ b/testing/py3-flask-restaction/APKBUILD
@@ -3,26 +3,30 @@
pkgname=py3-flask-restaction
_pkgname=flask-restaction
pkgver=0.25.3
-pkgrel=2
+pkgrel=7
pkgdesc="Flask RESTful API extension"
-url="https://pypi.python.org/pypi/flask-restaction"
+url="https://pypi.org/project/flask-restaction"
arch="noarch"
license="MIT"
# Has missing dependencies
depends="python3 py3-flask"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-flask-restaction" # Backwards compatibility
+replaces="py-flask-restaction" # Backwards compatibility
provides="py-flask-restaction=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="ac49d7547b036be9d0f40a632afce4df8718e2cb2cd205f93fd8ee6f560b894f8bc07fa00907ac92824d97001c4d8b9c99f92414ba69f4dbfe6a4e5955251c4e flask-restaction-0.25.3.tar.gz"