aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-fpdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-fpdf/APKBUILD')
-rw-r--r--testing/py3-fpdf/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-fpdf/APKBUILD b/testing/py3-fpdf/APKBUILD
index 618386a3128..6d355dc85dc 100644
--- a/testing/py3-fpdf/APKBUILD
+++ b/testing/py3-fpdf/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: MichaƂ Adamski <michal@ert.pl>
pkgname=py3-fpdf
pkgver=1.7.2
-pkgrel=1
+pkgrel=4
pkgdesc="Simple PDF generation for Python"
url="https://pyfpdf.readthedocs.io/en/latest/"
arch="noarch"
license="LGPL-3.0-or-later"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/f/fpdf/fpdf-$pkgver.tar.gz"
builddir="$srcdir/fpdf-$pkgver"
@@ -20,6 +21,6 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="3a4b4f363f36f821b5626b656b0ad199379aca171c7dd2a019e94f3bc39570b5624111d9fb3f8e0a7662e8f31184158e67263a475101378e84c200ebbbbcdd63 fpdf-1.7.2.tar.gz"