aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-fpdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-fpdf/APKBUILD')
-rw-r--r--testing/py3-fpdf/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-fpdf/APKBUILD b/testing/py3-fpdf/APKBUILD
new file mode 100644
index 00000000000..98e6a039fa3
--- /dev/null
+++ b/testing/py3-fpdf/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: MichaƂ Adamski <michal@ert.pl>
+pkgname=py3-fpdf
+pkgver=1.7.2
+pkgrel=5
+pkgdesc="Simple PDF generation for Python"
+url="https://pyfpdf.readthedocs.io/en/latest/"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/f/fpdf/fpdf-$pkgver.tar.gz"
+builddir="$srcdir/fpdf-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+sha512sums="3a4b4f363f36f821b5626b656b0ad199379aca171c7dd2a019e94f3bc39570b5624111d9fb3f8e0a7662e8f31184158e67263a475101378e84c200ebbbbcdd63 fpdf-1.7.2.tar.gz"