aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-funcparserlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-funcparserlib/APKBUILD')
-rw-r--r--testing/py3-funcparserlib/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/testing/py3-funcparserlib/APKBUILD b/testing/py3-funcparserlib/APKBUILD
index 5ae20831b48..b724d32627a 100644
--- a/testing/py3-funcparserlib/APKBUILD
+++ b/testing/py3-funcparserlib/APKBUILD
@@ -2,26 +2,32 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-funcparserlib
_pkgname=funcparserlib
-pkgver=0.3.6
-pkgrel=6
+pkgver=1.0.1
+pkgrel=4
pkgdesc="Recursive descent parsing library based on functional combinators"
url="https://github.com/vlasovskikh/funcparserlib"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-poetry-core py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-funcparserlib" # for backwards compatibility
+replaces="py-funcparserlib" # for backwards compatibility
provides="py-funcparserlib=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="efa52f788aa902b099660cb8bc60a025085a8c383e52bd0824a0c3ae28a6c13804a0659de0c80b4dcd839ee70491805d4eecda6cea221e35c3750ec569098c24 funcparserlib-0.3.6.tar.gz"
+sha512sums="
+721673b7d79c19cd3cbad8387297644790581057d077139fe6efbaa14bc5ad28dc9074b34728bdd9ea1c00c56c402ce329d9f53728e59030408fd87059339f79 funcparserlib-1.0.1.tar.gz
+"