aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-funcy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-funcy/APKBUILD')
-rw-r--r--testing/py3-funcy/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/testing/py3-funcy/APKBUILD b/testing/py3-funcy/APKBUILD
index 3b03f7d60ee..c6b6832dfd2 100644
--- a/testing/py3-funcy/APKBUILD
+++ b/testing/py3-funcy/APKBUILD
@@ -2,31 +2,28 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-funcy
_pkgname=funcy
-pkgver=1.10.3
-pkgrel=1
+pkgver=1.12
+pkgrel=0
pkgdesc="A fancy and practical functional tools"
url="https://github.com/Suor/funcy"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
checkdepends="py3-pytest py3-whatever"
-makedepends="python3-dev"
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/Suor/funcy/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 -m pytest .
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="3ea72a596818b9bc8f89bf002634f595859588e5a2558416ceffa5703db60880c7fbaef8c0f9654b5d7d70b58e3b7282b53c295218d540dbc2a8a5b481562bb4 py3-funcy-1.10.3.tar.gz"
+sha512sums="719ba558fea175a97ebe24ed7a8e9026638211ccb76678538f6fb9d879b443e9bf8eea1603105ab5d42ba9480c78a6792cde6b69d491d0d2fcda4edbe6687f5c py3-funcy-1.12.tar.gz"