aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-furl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-furl/APKBUILD')
-rw-r--r--testing/py3-furl/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/py3-furl/APKBUILD b/testing/py3-furl/APKBUILD
index cad72043038..828c12059e4 100644
--- a/testing/py3-furl/APKBUILD
+++ b/testing/py3-furl/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-furl
_pkgname=furl
-pkgver=2.1.0
-pkgrel=0
+pkgver=2.1.3
+pkgrel=2
pkgdesc="Python3 URL manipulator"
url="https://github.com/gruns/furl"
arch="noarch"
license="Unlicense"
depends="py3-orderedmultidict py3-six"
makedepends="py3-setuptools"
-checkdepends="py3-flake8 py3-pycodestyle py3-pyflakes"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+checkdepends="py3-pytest py3-flake8 py3-pycodestyle py3-pyflakes"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/f/furl/furl-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
@@ -19,11 +20,13 @@ build() {
}
check() {
- python3 setup.py test
+ PYTHONPATH="build:$PYTHONPATH" pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="c7de9c87e5368a3ccb7c0639b9c679b3c71ac75144f275b2491e88d361bfca8612b3b23e76e538a98b02c1666e2dac000cb9f5add2e97d240cead7f40a1411ca furl-2.1.0.tar.gz"
+sha512sums="
+ce7455bd1a352243efd9715e80e9f9979631cc058927edcd8c52ccb85d27fd8f32079611bb29c487d2add2d1d941d56e4db75520339dc371b1539811ccefda02 furl-2.1.3.tar.gz
+"