aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-gevent-websocket/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-gevent-websocket/APKBUILD')
-rw-r--r--testing/py3-gevent-websocket/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py3-gevent-websocket/APKBUILD b/testing/py3-gevent-websocket/APKBUILD
index 6957fac2b96..26cfadf5f23 100644
--- a/testing/py3-gevent-websocket/APKBUILD
+++ b/testing/py3-gevent-websocket/APKBUILD
@@ -3,14 +3,15 @@
pkgname=py3-gevent-websocket
_realname=gevent-websocket
pkgver=0.10.1
-pkgrel=2
+pkgrel=7
pkgdesc="gevent websockets library"
options="!check" # Requires unpackaged autobahntestsuite
-url="https://pypi.python.org/pypi/gevent-websocket/"
+url="https://pypi.org/project/gevent-websocket/"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-gevent"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/$_realname/$_realname-$pkgver.tar.gz"
replaces="py-geventwebsocket" # Backwards compat
@@ -23,7 +24,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="4f25ec1646c223b89ddbb7cf4decae72cc4baa6e872443dc05994987f509068a806c8b5e135c433d631e35b3902227f0e4c89d8071aa74e24c06b0e543e8df93 gevent-websocket-0.10.1.tar.gz"