aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-gls/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-gls/APKBUILD')
-rw-r--r--testing/py3-gls/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/testing/py3-gls/APKBUILD b/testing/py3-gls/APKBUILD
index 9b11f73e3f5..ec7e8f6644c 100644
--- a/testing/py3-gls/APKBUILD
+++ b/testing/py3-gls/APKBUILD
@@ -1,30 +1,37 @@
# Contributor: Galen Abell <galen@galenabell.com>
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=py3-gls
-pkgver=0.11.3
-pkgrel=0
+pkgver=1.3.1
+pkgrel=1
pkgdesc="pythonic generic language server"
url="https://github.com/openlawlibrary/pygls"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-pydantic py3-typeguard"
-makedepends="py3-setuptools py3-setuptools_scm py3-toml py3-wheel"
-checkdepends="py3-pytest py3-pytest-asyncio py3-mock"
-source="$pkgname-$pkgver.tar.gz::https://pypi.python.org/packages/source/p/pygls/pygls-$pkgver.tar.gz"
+depends="py3-lsprotocol py3-cattrs"
+makedepends="py3-gpep517 py3-wheel py3-poetry-core"
+checkdepends="py3-pytest py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/openlawlibrary/pygls/archive/refs/tags/v$pkgver.tar.gz
+ "
builddir="$srcdir/pygls-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="." pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-2209fa3f8cfd82de4edfe832f4e01ee8f805bbc145dca7f5f35d99919b2aace4a9c25fb61539d065509e163dc3db51cf8ec17b163ffd7ed4a25f33ac0c520a11 py3-gls-0.11.3.tar.gz
+ef5d516d2da7e747fafd0a333157a964efcc7bcb424b2171451eb4f4084ada40ea2294cfa2322201b052a10f2958cbf2ea05748fbf7890bc4fbf6d82e154f9d4 py3-gls-1.3.1.tar.gz
"