aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-googletrans/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-googletrans/APKBUILD')
-rw-r--r--testing/py3-googletrans/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/py3-googletrans/APKBUILD b/testing/py3-googletrans/APKBUILD
new file mode 100644
index 00000000000..7c78a51683f
--- /dev/null
+++ b/testing/py3-googletrans/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Eloi Torrents <eloitor@disroot.org>
+# Maintainer: Eloi Torrents <eloitor@disroot.org>
+pkgname=py3-googletrans
+pkgver=3.0.0
+pkgrel=4
+pkgdesc="Free Google Translate API for Python"
+url="https://py-googletrans.readthedocs.io/en/latest/"
+arch="noarch !armhf !ppc64le" # missing py3-httpx
+license="MIT"
+depends="
+ py3-httpx
+ python3
+ "
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="
+ https://pypi.io/packages/source/g/googletrans/googletrans-$pkgver.tar.gz
+ client.patch
+ "
+builddir="$srcdir/googletrans-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+1a31c52e1fc72ab45131c95ff3649d1d679e3c082adc2b43ba1e5d9bbc57bf740c9e14575c6416e406e6e6e1796cac57330fbb1a639ad96841464e042ef70981 googletrans-3.0.0.tar.gz
+00eaccaa3da8ebc7d18cde5970683667871fe849b510ce7609ee2b7a3c84d4fa60e89a51104be3b90f6fcff79580e6c438a5411a94fa7e846fcab6061409a062 client.patch
+"