aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-grequests/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-grequests/APKBUILD')
-rw-r--r--testing/py3-grequests/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py3-grequests/APKBUILD b/testing/py3-grequests/APKBUILD
new file mode 100644
index 00000000000..7a3f27cf1d5
--- /dev/null
+++ b/testing/py3-grequests/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Dmitry Zakharchenko <dmitz@disroot.org>
+# Maintainer: Dmitry Zakharchenko <dmitz@disroot.org>
+pkgname=py3-grequests
+_pkgname=grequests
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Asynchronus HTTP requests with gevent"
+url="https://github.com/spyoungtech/grequests"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3 py3-gevent py3-requests"
+makedepends="py3-setuptools"
+checkdepends="py3-nose"
+subpackages="$pkgname-pyc"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/spyoungtech/grequests/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # need net to httpbin and timeout quickly
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ nosetests
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+ff3e57c7ed8ea643ad0b7a1987216e98de77d650807037a3c953f8fdb8e9a0090d79debb54205a13934c10043e4d3693336b9d9c1b5342fef383221bfefd5330 grequests-0.7.0.tar.gz
+"