aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-h2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-h2/APKBUILD')
-rw-r--r--testing/py3-h2/APKBUILD38
1 files changed, 0 insertions, 38 deletions
diff --git a/testing/py3-h2/APKBUILD b/testing/py3-h2/APKBUILD
deleted file mode 100644
index 290092da8eb..00000000000
--- a/testing/py3-h2/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: André Klitzing <aklitzing@gmail.com>
-# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: André Klitzing <aklitzing@gmail.com>
-pkgname=py3-h2
-_pkgname=hyper-h2
-pkgver=4.0.0
-pkgrel=0
-pkgdesc="HTTP/2 State-Machine based protocol implementation"
-url="https://python-hyper.org/h2/"
-arch="noarch"
-license="MIT"
-depends="
- python3
- py3-hyperframe
- py3-hpack
- "
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-hypothesis"
-source="$pkgname-$pkgver.tar.gz::https://github.com/python-hyper/hyper-h2/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-[ "$CARCH" = "mips64" ] && options="!check" # tests too slow on mips64
-
-replaces="py-h2" # Backwards compatibility
-provides="py-h2=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- PYTHONPATH="$PWD/build/lib" python3 -m pytest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="84578174a13782897f9286c62d450eaf11aa71c01c96b8660179cd2df77618dc1a6c4b354b2bc5731cd21c4709c8c0a8282a859a98c4a62a7295b6dfd1b5cfb2 py3-h2-4.0.0.tar.gz"