aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-halo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-halo/APKBUILD')
-rw-r--r--testing/py3-halo/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-halo/APKBUILD b/testing/py3-halo/APKBUILD
index 02b58ccb5ad..f9655fc392a 100644
--- a/testing/py3-halo/APKBUILD
+++ b/testing/py3-halo/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-halo
_pyname=halo
pkgver=0.0.31
-pkgrel=0
+pkgrel=3
pkgdesc="Python library for terminal spinners"
url="https://github.com/manrajgrover/halo"
arch="noarch"
@@ -11,6 +11,7 @@ license="MIT"
depends="python3 py3-log-symbols py3-spinners py3-termcolor py3-colorama py3-six"
makedepends="py3-setuptools"
options="!check" # no tests
+subpackages="$pkgname-pyc"
source="$_pyname-$pkgver.tar.gz::https://pypi.python.org/packages/source/h/halo/halo-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -19,7 +20,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="