aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hbmqtt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-hbmqtt/APKBUILD')
-rw-r--r--testing/py3-hbmqtt/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/py3-hbmqtt/APKBUILD b/testing/py3-hbmqtt/APKBUILD
deleted file mode 100644
index ef65ff88b63..00000000000
--- a/testing/py3-hbmqtt/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-hbmqtt
-_pkgname=hbmqtt
-pkgver=0.9.6
-pkgrel=1
-pkgdesc="MQTT client/broker using Python asynchronous I/O"
-url="https://hbmqtt.readthedocs.io/"
-arch="noarch"
-license="MIT"
-depends="py3-passlib py3-websockets py3-transitions py3-docopt py3-yaml"
-makedepends="python3-dev py3-setuptools"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/beerfactory/hbmqtt/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-options="!check" # FIXME: disable tests to unblock builders
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python3 setup.py test
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --root="$pkgdir" --optimize=1
-}
-
-sha512sums="dbbdd328296cb9545f4ea8843fdc951c72c53b54f87a6c589c8d19fa34d2f48a2fb902a918f34196009740b4b6574dc8aabd5c408dcea2905cbb7094238be834 hbmqtt-0.9.6.tar.gz"