aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hotqueue/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-hotqueue/APKBUILD')
-rw-r--r--testing/py3-hotqueue/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/py3-hotqueue/APKBUILD b/testing/py3-hotqueue/APKBUILD
deleted file mode 100644
index 252a0f239ff..00000000000
--- a/testing/py3-hotqueue/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-hotqueue
-_pkgname=hotqueue
-pkgver=0.2.8
-pkgrel=5
-pkgdesc="Python library that allows to use Redis as a message queue"
-options="!check" # Require running instance of redis server
-url="https://github.com/richardhenry/hotqueue"
-arch="noarch !armv7" # urllib2.HTTPError: HTTP Error 403: SSL is required
-license="MIT"
-depends="py3-redis"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-replaces="py-hotqueue" # Backwards compatibility
-provides="py-hotqueue=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="89a726aa970de5f0a3c3551e69b3efad00d6b795b59cfe219a35080be4be52b894637899cd1677572419180d8aa918a64b3d227371d2c409aa8da0e15876accf hotqueue-0.2.8.tar.gz"