aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-humanize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-humanize/APKBUILD')
-rw-r--r--testing/py3-humanize/APKBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/testing/py3-humanize/APKBUILD b/testing/py3-humanize/APKBUILD
deleted file mode 100644
index b39f30c778a..00000000000
--- a/testing/py3-humanize/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Contributor: Thomas Boerger <thomas@webhippie.de>
-# Maintainer: Thomas Boerger <thomas@webhippie.de>
-pkgname=py3-humanize
-_pkgname=humanize
-pkgver=3.3.0
-pkgrel=1
-pkgdesc="Python humanize functions"
-options="!check" # No tests are actually run
-url="https://pypi.python.org/pypi/humanize"
-arch="noarch"
-license="MIT"
-depends="python3"
-makedepends="py3-setuptools py3-setuptools_scm"
-checkdepends="py3-mock py3-freezegun py3-pytest"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/jmoiron/humanize/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-replaces=py-humanize # Backwards compatibility
-provides=py-humanize=$pkgver-r$pkgrel # Backwards compatibility
-
-build() {
- git init
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="7099775c539ff8a290e40c186581540280dffa5e7065e66041aa74fa4f348ac2ab622781e0f4dae798acda25689287b6a5811e7f19128e3fbd93b6c3a6ba29d4 humanize-3.3.0.tar.gz"