aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-i18naddress/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-i18naddress/APKBUILD')
-rw-r--r--testing/py3-i18naddress/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/testing/py3-i18naddress/APKBUILD b/testing/py3-i18naddress/APKBUILD
index c1cfb0fcd6c..8b9ce680505 100644
--- a/testing/py3-i18naddress/APKBUILD
+++ b/testing/py3-i18naddress/APKBUILD
@@ -1,32 +1,38 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-i18naddress
_pyname=google-i18n-address
-pkgver=2.4.0
-pkgrel=1
+pkgver=3.1.0
+pkgrel=2
pkgdesc="Address validation helpers for Google's i18n address database"
url="https://github.com/mirumee/google-i18n-address"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-requests"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-hatchling py3-installer py3-wheel"
checkdepends="py3-pytest"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz
- python-3.9.patch"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mirumee/google-i18n-address/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- py.test-3
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --root="$pkgdir" --optimize=1
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="a64e598b838f9d83b70b4f6acb3dc6c8930239e44b726f39a8f973334e2927d0394d1f323ca53acd43f4d9abede2a7ee48427f48a90427cbae7aada4cd8f08a5 google-i18n-address-2.4.0.tar.gz
-b4538f0acdcd8fced7c2d6372428dda4fbcb61eed2d8acc1b9e77a1147ba8d7ee8e4f6b0b63c16d50533c8cbea933157aed8a09b14b5664170303f602d0b25ad python-3.9.patch"
+sha512sums="
+b47b5eeaf214a04614ed0976055d25fbce2d298c45db4bfe31b369cd27dc1e097b14d4fae62b5f8dd95be5693d2fda12d0b618029dc1f3ed2784e28b60c43ef9 py3-i18naddress-3.1.0.tar.gz
+"