aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-identify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-identify/APKBUILD')
-rw-r--r--testing/py3-identify/APKBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/testing/py3-identify/APKBUILD b/testing/py3-identify/APKBUILD
deleted file mode 100644
index 213d86146be..00000000000
--- a/testing/py3-identify/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Galen Abell <galen@galenabell.com>
-# Maintainer: Galen Abell <galen@galenabell.com>
-pkgname=py3-identify
-_pyname=identify
-pkgver=2.3.0
-pkgrel=0
-pkgdesc="File identification library for Python"
-url="https://github.com/pre-commit/identify"
-arch="noarch"
-license="MIT"
-depends="python3 py3-editdistance-s"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="$_pyname-$pkgver.tar.gz::https://github.com/pre-commit/identify/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/$_pyname-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- pytest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-356e3c983273a771c06863a63fb53bdca9e3df3a50382f47da0d5ef7cee1b83d9279eb0d1e6c28409b2550f6e16eb793901147983582d792cdd39bb4d4c6e9f1 identify-2.3.0.tar.gz
-"