aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-intervals/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-intervals/APKBUILD')
-rw-r--r--testing/py3-intervals/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-intervals/APKBUILD b/testing/py3-intervals/APKBUILD
index 1f303f4f173..6321ad2cc60 100644
--- a/testing/py3-intervals/APKBUILD
+++ b/testing/py3-intervals/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-intervals
_pkgname=intervals
-pkgver=0.9.0
-pkgrel=0
+pkgver=0.9.2
+pkgrel=4
pkgdesc="Python module for handling intervals (ranges of comparable objects)"
url="https://github.com/kvesteri/intervals"
arch="noarch"
@@ -11,6 +11,7 @@ license="BSD-3-Clause"
depends="py3-infinity"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
pytest5.patch"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -27,8 +28,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="474ce8fadaf5e884b1cf2f429497e0c234ef18b47592bd9a8e71eacae75abd5605c22153a2649123bfb7132272a8fa75009f4c8c872baf689528319f0af503d3 intervals-0.9.0.tar.gz
-af545bec7d8157259197e045396d69ac1791b5e0420056fca69bea444cceacaa208ae568fd80792f614e1c775611ea22c48521bdd47dbdd976a699c150835f96 pytest5.patch"
+sha512sums="
+40da5f7630bc84dbd47196e7e84f94701730b4f2ee71294edfaecfc9187f5c05333fc79502c315d5962c29c9c2a50c8e471980c98764d7c0581d33383a487e4a intervals-0.9.2.tar.gz
+af545bec7d8157259197e045396d69ac1791b5e0420056fca69bea444cceacaa208ae568fd80792f614e1c775611ea22c48521bdd47dbdd976a699c150835f96 pytest5.patch
+"