aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-intervals/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-intervals/APKBUILD')
-rw-r--r--testing/py3-intervals/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-intervals/APKBUILD b/testing/py3-intervals/APKBUILD
index 30a8bfca75e..6321ad2cc60 100644
--- a/testing/py3-intervals/APKBUILD
+++ b/testing/py3-intervals/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-intervals
_pkgname=intervals
pkgver=0.9.2
-pkgrel=0
+pkgrel=4
pkgdesc="Python module for handling intervals (ranges of comparable objects)"
url="https://github.com/kvesteri/intervals"
arch="noarch"
@@ -11,6 +11,7 @@ license="BSD-3-Clause"
depends="py3-infinity"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
pytest5.patch"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -27,7 +28,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="