aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-intervals/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-intervals/APKBUILD')
-rw-r--r--testing/py3-intervals/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/testing/py3-intervals/APKBUILD b/testing/py3-intervals/APKBUILD
index 3fb720232a5..6321ad2cc60 100644
--- a/testing/py3-intervals/APKBUILD
+++ b/testing/py3-intervals/APKBUILD
@@ -2,16 +2,18 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-intervals
_pkgname=intervals
-pkgver=0.8.1
-pkgrel=0
-pkgdesc="A Python module for handling intervals (ranges of comparable objects)"
+pkgver=0.9.2
+pkgrel=4
+pkgdesc="Python module for handling intervals (ranges of comparable objects)"
url="https://github.com/kvesteri/intervals"
arch="noarch"
license="BSD-3-Clause"
depends="py3-infinity"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ pytest5.patch"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-intervals" # Backwards compatibility
@@ -26,7 +28,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="f97142d5f1c8d4da21692b856803481878ac2b2afc3b81937de456bacbf66ebb129b1fe9a070ac442cbc6bbe26fdaf2ed839f8fc8b26392b4bd1ce032d054e65 intervals-0.8.1.tar.gz"
+sha512sums="
+40da5f7630bc84dbd47196e7e84f94701730b4f2ee71294edfaecfc9187f5c05333fc79502c315d5962c29c9c2a50c8e471980c98764d7c0581d33383a487e4a intervals-0.9.2.tar.gz
+af545bec7d8157259197e045396d69ac1791b5e0420056fca69bea444cceacaa208ae568fd80792f614e1c775611ea22c48521bdd47dbdd976a699c150835f96 pytest5.patch
+"