aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-invoke/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-invoke/APKBUILD')
-rw-r--r--testing/py3-invoke/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/testing/py3-invoke/APKBUILD b/testing/py3-invoke/APKBUILD
index b107e6a4a45..f48abf397f5 100644
--- a/testing/py3-invoke/APKBUILD
+++ b/testing/py3-invoke/APKBUILD
@@ -1,25 +1,34 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-invoke
-_pkgname=invoke
-pkgver=1.5.0
+pkgver=2.2.0
pkgrel=2
pkgdesc="Pythonic task execution"
options="!check" # Can't find invoke.vendor.six
-url="http://docs.pyinvoke.org/en/1.3/"
+url="https://www.pyinvoke.org/"
arch="noarch"
license="BSD-2-Clause"
-depends="python3 py3-yaml"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+depends="py3-yaml"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pyinvoke/invoke/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/invoke-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ac6b1939907ba34930836f567454aeea63373aa510644964eb18e1e684f30d4053c75a73506d0e947a38ca206daf847ce927ec2df15e73932278c2c73c3e20bd invoke-1.5.0.tar.gz"
+sha512sums="
+3d0adabec4825fb45524d3ab4f2a790d31245a89e038c08c770fc9f33c81ed182769e8f17d3d6f33a913b431cba475b975826ddfd533a945d481b52deba759a2 py3-invoke-2.2.0.tar.gz
+"