aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-itunespy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-itunespy/APKBUILD')
-rw-r--r--testing/py3-itunespy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-itunespy/APKBUILD b/testing/py3-itunespy/APKBUILD
new file mode 100644
index 00000000000..eb3a503a632
--- /dev/null
+++ b/testing/py3-itunespy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Dmitry Zakharchenko <dmitz@disroot.org>
+# Maintainer: Dmitry Zakharchenko <dmitz@disroot.org>
+pkgname=py3-itunespy
+_pkgname=itunespy
+pkgver=1.6
+pkgrel=3
+pkgdesc="Library to fetch data from the iTunes Store API"
+url="https://github.com/sleepyfran/itunespy"
+arch="noarch"
+license="MIT"
+depends="py3-requests py3-pycountry"
+makedepends="py3-setuptools"
+options="!check" # no test suite
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sleepyfran/itunespy/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+d91428e23a71bdbc62e6b8126b379aa48f06a365056147cf30eb4fa6132243d35c8a8d6dc536174a53f206bf7bcb4dcebb5a3697fac0fd88cbcb38205202ad81 py3-itunespy-1.6.tar.gz
+"