aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-janus/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-janus/APKBUILD')
-rw-r--r--testing/py3-janus/APKBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/testing/py3-janus/APKBUILD b/testing/py3-janus/APKBUILD
index 402bd410d51..839bb4145ab 100644
--- a/testing/py3-janus/APKBUILD
+++ b/testing/py3-janus/APKBUILD
@@ -1,28 +1,38 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=py3-janus
-pkgver=0.6.1
-pkgrel=0
+pkgver=1.0.0
+pkgrel=2
pkgdesc="Mixed sync-async queue to interoperate between asyncio tasks and classic threads"
url="https://github.com/aio-libs/janus/"
arch="noarch"
license="Apache-2.0"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest py3-pytest-asyncio py3-pytest-regtest"
-source="https://files.pythonhosted.org/packages/source/j/janus/janus-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/j/janus/janus-$pkgver.tar.gz
+ no-typing-extensions.patch
+ "
builddir="$srcdir/janus-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="7b54c0a1f9b457dd8bfe5de69d2d3e22a8b8b26570b6956fcfd943bf94f060b4b4a59cfac5e522af25fd037333d19e07e5b9ceb23b0116006bde930815ee9f63 janus-0.6.1.tar.gz"
+sha512sums="
+d66899adad12cc1100a20cb75d8e146321ef947bde996a07490158a5f34c39421bb1a5b08ac87679264a6bee1d3dc9f425fa29d52199626d322fe4462ed8f1f3 janus-1.0.0.tar.gz
+53723d86b73fe8dc135aa5e462fb00c1824ce0dbeacef449a38891860e5fb2058bbe31f5d7f1c1534b51fe6d08498d418a549e30508fffa0418be78c6910e547 no-typing-extensions.patch
+"